ADMS-FT1D Programming Software Only for the Yaesu FT-1D
ADMS-FT1D Programming Software Only for the Yaesu FT-1D

ADMS-FT1D Programming Software Only for the Yaesu FT-1D

20 Review(s) Write a Review
Your Price: $25.00
Program memories and other settings of the Yaesu FT-1D radio.

Includes:

  • ADMS-FT1D Software

Requires:

  • USB-68 Cable
  • Microsoft Windows 8/8.1, 10 (32 or 64 Bit), or Win 11
  • OR

  • MacOS 10.11.6 or higher (64-bit)
Works only with the RT Systems USB-68 cable. Verify your cable is the one shown below.
More Information: .
SCU-18 or SCU-19 cables may not work on Windows 11
*
*
RT Systems ADMS-FT1D Programming software makes it easy to manage memory channel information and other menu settings of the Yaesu FT-1D.

The radio can be programmed with the RT Systems USB-68 cable (available from this site), the Yaesu SCU-18 or SCU-19 cable (although those might not work on Win 11: See more details on this issue here ), or with a Micro SD card (class 4 best). Click here for step by step details about using the SD card for programming the radio.

  • Spreadsheet layout with many point and click options.
  • "Read" the current configuration from the radio for editing or start from scratch in a new file.
  • The programmer has copy and paste of memory channel information between files.
  • Column editing for changing several channels with minimal typing.
  • An easy interface to RFinder-Worldwide Repeater Directory, Radio Reference, or Repeater Book to get repeater information for your location, a travel route, or a vacation spot. Repeater details available for locations in and outside the US. (separate purchase or subscription may be required)
  • Other built-in frequency lists for easy memory channel entries (check File|External data in the programmer before you spend time on internet searches for frequencies. You may find just what you need!)
  • Copy and paste spreadsheet or website data.
  • Much more than just memory channel programming with settings for other radio menu items.
  • RT Systems Programming Software for the
    • Windows version requires Windows 8/8.1 (full version), Windows 10 for 32 and 64 bit platforms or Windows 11.
    • Mac version requires Mac OS X 10.11.6 (64-bit) or newer.

Related Items

TOP